re = /(\/classification\/showIndividualStageClassification\/|\/classification\/showIndividualLeagueClassification\/)(.*)/
str = '/classification/showIndividualStageClassification/9371
/classification/showIndividualLeagueClassification/3026'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result