use strict;
my $str = '/classification/showIndividualStageClassification/9371
/classification/showIndividualLeagueClassification/3026';
my $regex = qr/(\/classification\/showIndividualStageClassification\/|\/classification\/showIndividualLeagueClassification\/)(.*)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";