import Foundation
let pattern = #"(\/classification\/showIndividualStageClassification\/|\/classification\/showIndividualLeagueClassification\/)(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
/classification/showIndividualStageClassification/9371
/classification/showIndividualLeagueClassification/3026
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)