$re = '/(\/classification\/showIndividualStageClassification\/|\/classification\/showIndividualLeagueClassification\/)(.*)/';
$str = '/classification/showIndividualStageClassification/9371
/classification/showIndividualLeagueClassification/3026';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;