# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^References:|\G(?!\A)).*?@\Kdomain-a\.com/domain-b.com/gm;t' <<< "References: <mail-1@domain-a.com> <mail-2@domain-a.com> <mail-3@domain-a.com>
Another-Header: <example@domain-a.com>
"