use strict;
my $str = 'References: <mail-1@domain-a.com> <mail-2@domain-a.com> <mail-3@domain-a.com>
Another-Header: <example@domain-a.com>
';
my $regex = qr/(^References:|\G(?!\A)).*?@\Kdomain-a\.com/mp;
my $subst = 'domain-b.com';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";