re = /(^References:|\G(?!\A)).*?@\Kdomain-a\.com/m
str = 'References: <mail-1@domain-a.com> <mail-2@domain-a.com> <mail-3@domain-a.com>
Another-Header: <example@domain-a.com>
'
subst = 'domain-b.com'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result