# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^References:|\G(?!\A)).*?@\Kdomain-a\.com"
test_str = ("References: <mail-1@domain-a.com> <mail-2@domain-a.com> <mail-3@domain-a.com>\n"
"Another-Header: <example@domain-a.com>\n")
subst = "domain-b.com"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.