#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^References:|\G(?!\A)).*?@\Kdomain-a\.com"
Local $sString = "References: <mail-1@domain-a.com> <mail-2@domain-a.com> <mail-3@domain-a.com>" & @CRLF & _
"Another-Header: <example@domain-a.com>" & @CRLF & _
""
Local $sSubst = "domain-b.com"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)