import Foundation
let pattern = #"(^References:|\G(?!\A)).*?@\Kdomain-a\.com"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
References: <mail-1@domain-a.com> <mail-2@domain-a.com> <mail-3@domain-a.com>
Another-Header: <example@domain-a.com>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"domain-b.com"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)