const regex = /(^References:|\G(?!\A)).*?@\Kdomain-a\.com/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^References:|\\G(?!\\A)).*?@\\Kdomain-a\\.com', 'gm')
const str = `References: <mail-1@domain-a.com> <mail-2@domain-a.com> <mail-3@domain-a.com>
Another-Header: <example@domain-a.com>
`;
const subst = `domain-b.com`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);