import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\bel\\{([^\\}]*)\\}\\{([^\\}]*)\\}";
final String string = "\\newline\\newline$\\FA{\\bel{K, L}{\\Class}}(\\rown{K = L}{\\FA{x}(\\rown{\\bel{x}{K}}{\\bel{x}{L}})})$";
final String subst = "\\1 : \\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}