// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\\bel{([^}]*)}{([^}]*)}").unwrap();
let string = "\\newline\\newline$\\FA{\\bel{K, L}{\\Class}}(\\rown{K = L}{\\FA{x}(\\rown{\\bel{x}{K}}{\\bel{x}{L}})})$";
let substitution = "\\1 : \\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}