# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/якорь|\[special\].*?\[\/special\](*SKIP)(*F)/TXT/gs;t' <<< "К примеру есть какой то текст:
\"текст текст якорь текст [special] текст текст текст якорь текст [/special] текст текст якорь текст\""