// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)якорь|\[special\].*?\[/special\](*SKIP)(*F)").unwrap();
let string = "К примеру есть какой то текст:
\"текст текст якорь текст [special] текст текст текст якорь текст [/special] текст текст якорь текст\"";
let substitution = "TXT";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}