package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)якорь|\[special\].*?\[/special\](*SKIP)(*F)`)
var str = `К примеру есть какой то текст:
"текст текст якорь текст [special] текст текст текст якорь текст [/special] текст текст якорь текст"`
var substitution = "TXT"
fmt.Println(re.ReplaceAllString(str, substitution))
}