re = /якорь|\[special\].*?\[\/special\](*SKIP)(*F)/
str = 'К примеру есть какой то текст:
"текст текст якорь текст [special] текст текст текст якорь текст [/special] текст текст якорь текст"'
subst = 'TXT'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result