import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "якорь|\\[special\\].*?\\[/special\\](*SKIP)(*F)";
final String string = "К примеру есть какой то текст:\n\n"
+ "\"текст текст якорь текст [special] текст текст текст якорь текст [/special] текст текст якорь текст\"";
final String subst = "TXT";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}