use strict;
my $str = 'К примеру есть какой то текст:
"текст текст якорь текст [special] текст текст текст якорь текст [/special] текст текст якорь текст"';
my $regex = qr#якорь|\[special\].*?\[/special\](*SKIP)(*F)#sp;
my $subst = 'TXT';
my $result = $str =~ s#$regex#$subst#rg;
print "The result of the substitution is' $result\n";