using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"якорь|\[special\].*?\[/special\](*SKIP)(*F)";
string substitution = @"TXT";
string input = @"К примеру есть какой то текст:
""текст текст якорь текст [special] текст текст текст якорь текст [/special] текст текст якорь текст""";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}