# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(h[1-6])>(.+)(\s+)([^\s]+)<\\/\1>/<$1>$2 $4<\\/$1>/gim;t' <<< "<h2>This is a test heading</h2>
<p>Here is some text</p>
<div>
<h3>Here is a another heading</h3>
<p>Some more paragraph text which shouldn't match</p>
</div>
<h2>This is a test heading</h2>
<p>Here is some text</p>
<div>
<h3>Here is a another heading</h3>
<p>Some more paragraph text which shouldn't match</p>
</div>"