import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(h[1-6])>(.+)(\\s+)([^\\s]+)<\\/\\1>";
final String string = "<h2>This is a test heading</h2>\n"
+ "<p>Here is some text</p>\n"
+ "<div>\n"
+ " <h3>Here is a another heading</h3>\n"
+ " <p>Some more paragraph text which shouldn't match</p>\n"
+ "</div>\n"
+ "<h2>This is a test heading</h2>\n"
+ "<p>Here is some text</p>\n"
+ "<div>\n"
+ " <h3>Here is a another heading</h3>\n"
+ " <p>Some more paragraph text which shouldn't match</p>\n"
+ "</div>";
final String subst = "<$1>$2 $4<\\/$1>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}