#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)<(h[1-6])>(.+)(\s+)([^\s]+)<\/\1>"
Local $sString = "<h2>This is a test heading</h2>" & @CRLF & _
"<p>Here is some text</p>" & @CRLF & _
"<div>" & @CRLF & _
" <h3>Here is a another heading</h3>" & @CRLF & _
" <p>Some more paragraph text which shouldn't match</p>" & @CRLF & _
"</div>" & @CRLF & _
"<h2>This is a test heading</h2>" & @CRLF & _
"<p>Here is some text</p>" & @CRLF & _
"<div>" & @CRLF & _
" <h3>Here is a another heading</h3>" & @CRLF & _
" <p>Some more paragraph text which shouldn't match</p>" & @CRLF & _
"</div>"
Local $sSubst = "<$1>$2 $4<\/$1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)