const regex = /<(h[1-6])>(.+)(\s+)([^\s]+)<\/\1>/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(h[1-6])>(.+)(\\s+)([^\\s]+)<\\\/\\1>', 'gim')
const str = `<h2>This is a test heading</h2>
<p>Here is some text</p>
<div>
<h3>Here is a another heading</h3>
<p>Some more paragraph text which shouldn't match</p>
</div>
<h2>This is a test heading</h2>
<p>Here is some text</p>
<div>
<h3>Here is a another heading</h3>
<p>Some more paragraph text which shouldn't match</p>
</div>`;
const subst = `<$1>$2 $4<\/$1>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);