# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<(h[1-6])>(.+)(\s+)([^\s]+)<\/\1>"
test_str = ("<h2>This is a test heading</h2>\n"
"<p>Here is some text</p>\n"
"<div>\n"
" <h3>Here is a another heading</h3>\n"
" <p>Some more paragraph text which shouldn't match</p>\n"
"</div>\n"
"<h2>This is a test heading</h2>\n"
"<p>Here is some text</p>\n"
"<div>\n"
" <h3>Here is a another heading</h3>\n"
" <p>Some more paragraph text which shouldn't match</p>\n"
"</div>")
subst = "<$1>$2 $4<\\/$1>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.