re = /<(h[1-6])>(.+)(\s+)([^\s]+)<\/\1>/im
str = '<h2>This is a test heading</h2>
<p>Here is some text</p>
<div>
<h3>Here is a another heading</h3>
<p>Some more paragraph text which shouldn\'t match</p>
</div>
<h2>This is a test heading</h2>
<p>Here is some text</p>
<div>
<h3>Here is a another heading</h3>
<p>Some more paragraph text which shouldn\'t match</p>
</div>'
subst = '<$1>$2 $4<\\/$1>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result