import Foundation
let pattern = #"<(h[1-6])>(.+)(\s+)([^\s]+)<\/\1>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
<h2>This is a test heading</h2>
<p>Here is some text</p>
<div>
<h3>Here is a another heading</h3>
<p>Some more paragraph text which shouldn't match</p>
</div>
<h2>This is a test heading</h2>
<p>Here is some text</p>
<div>
<h3>Here is a another heading</h3>
<p>Some more paragraph text which shouldn't match</p>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<$1>$2 $4<\/$1>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)