using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(h[1-6])>(.+)(\s+)([^\s]+)<\/\1>";
string substitution = @"<$1>$2 $4<\/$1>";
string input = @"<h2>This is a test heading</h2>
<p>Here is some text</p>
<div>
<h3>Here is a another heading</h3>
<p>Some more paragraph text which shouldn't match</p>
</div>
<h2>This is a test heading</h2>
<p>Here is some text</p>
<div>
<h3>Here is a another heading</h3>
<p>Some more paragraph text which shouldn't match</p>
</div>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}