#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^{map:\h+geo="(?P<lat>-?\d+(?:\.\d+(?:,\d+)?)?),(?P<lon>-?\d+(?:\.\d+(?:,\d+)?)?)"[^}]+}"
Local $sString = "{map: geo="20.471884,-157.505,6" p="Hawaii"}" & @CRLF & _
"{map: geo="-157.505,6,-20.471884,5" p="Hawaii"}" & @CRLF & _
"{map: geo="-157.505,6,20.471884" p="Hawaii"}" & @CRLF & _
"{map: geo="157,11111" p="Hawaii"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")