import re
regex = re.compile(r"^{map:\h+geo=\"(?P<lat>-?\d+(?:\.\d+(?:,\d+)?)?),(?P<lon>-?\d+(?:\.\d+(?:,\d+)?)?)\"[^}]+}", flags=re.MULTILINE)
test_str = ("{map: geo=\"20.471884,-157.505,6\" p=\"Hawaii\"}\n"
"{map: geo=\"-157.505,6,-20.471884,5\" p=\"Hawaii\"}\n"
"{map: geo=\"-157.505,6,20.471884\" p=\"Hawaii\"}\n"
"{map: geo=\"157,11111\" p=\"Hawaii\"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")