$re = '/^{map:\h+geo="(?P<lat>-?\d+(?:\.\d+(?:,\d+)?)?),(?P<lon>-?\d+(?:\.\d+(?:,\d+)?)?)"[^}]+}/m';
$str = '{map: geo="20.471884,-157.505,6" p="Hawaii"}
{map: geo="-157.505,6,-20.471884,5" p="Hawaii"}
{map: geo="-157.505,6,20.471884" p="Hawaii"}
{map: geo="157,11111" p="Hawaii"}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);