import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\{map:\\h+geo=\"(?P<lat>-?\\d+(?:\\.\\d+(?:,\\d+)?)?),(?P<lon>-?\\d+(?:\\.\\d+(?:,\\d+)?)?)\"[^\\}]+\\}";
final String string = "{map: geo=\"20.471884,-157.505,6\" p=\"Hawaii\"}\n"
+ "{map: geo=\"-157.505,6,-20.471884,5\" p=\"Hawaii\"}\n"
+ "{map: geo=\"-157.505,6,20.471884\" p=\"Hawaii\"}\n"
+ "{map: geo=\"157,11111\" p=\"Hawaii\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}