# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\<(\\/?[^>]+)>)//gm;t' <<< "<div id=\"div\">
dgdivdivdiv div divdivfgsdfa
</div>
<p id=\"p\" >
pppppppppp p ppphjyerw
</p><div id=\"div\">
dgdivdivdivdiv div divfgsdfa
</div>"