re = /(\<(\/?[^>]+)>)/m
str = '<div id="div">
dgdivdivdiv div divdivfgsdfa
</div>
<p id="p" >
pppppppppp p ppphjyerw
</p><div id="div">
dgdivdivdivdiv div divfgsdfa
</div>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result