import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\<(\\/?[^>]+)>)";
final String string = "<div id=\"div\">\n"
+ "dgdivdivdiv div divdivfgsdfa\n"
+ "</div>\n"
+ "<p id=\"p\" >\n"
+ "pppppppppp p ppphjyerw\n"
+ "</p><div id=\"div\">\n"
+ "dgdivdivdivdiv div divfgsdfa\n"
+ "</div>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}