const regex = /(\<(\/?[^>]+)>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\<(\\\/?[^>]+)>)', 'gm')
const str = `<div id="div">
dgdivdivdiv div divdivfgsdfa
</div>
<p id="p" >
pppppppppp p ppphjyerw
</p><div id="div">
dgdivdivdivdiv div divfgsdfa
</div>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);