using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\/\/\s*?)(?:var|let|const)(?:\s+)(.*?)(?:\s+)?=\s?(?:.*?);";
string substitution = @"{{$1}}";
string input = @"// start file
var nameVar1 = '';
// var nameVar1 = '';
var otherVar1= ""test1"";
var nameVar2 =""test2"",
otherVar2 = 'test3';
var nameVar3 = true;
var otherVar3 = false ;
var objName = {
test: 'test'
};
var expression = nameVar1 + nameVar2;
// comment
for(var test in templateConfig) {
if( templateConfig ){ defaultLang = langParam; }
}
// end file";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}