$re = '/(?<!\/\/\s*?)(?:var|let|const)(?:\s+)(.*?)(?:\s+)?=\s?(?:.*?);/ms';
$str = '// start file
var nameVar1 = \'\';
// var nameVar1 = \'\';
var otherVar1= "test1";
var nameVar2 ="test2",
otherVar2 = \'test3\';
var nameVar3 = true;
var otherVar3 = false ;
var objName = {
test: \'test\'
};
var expression = nameVar1 + nameVar2;
// comment
for(var test in templateConfig) {
if( templateConfig ){ defaultLang = langParam; }
}
// end file';
$subst = "{{$1}}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;