# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\/\/\s*?)(?:var|let|const)(?:\s+)(.*?)(?:\s+)?=\s?(?:.*?);"
test_str = ("// start file\n\n"
"var nameVar1 = '';\n"
"// var nameVar1 = '';\n\n"
"var otherVar1= \"test1\";\n\n"
"var nameVar2 =\"test2\",\n"
" otherVar2 = 'test3';\n"
" \n"
"var nameVar3 = true;\n\n"
"var otherVar3 = false ;\n\n"
"var objName = {\n"
" test: 'test'\n"
"};\n\n"
"var expression = nameVar1 + nameVar2;\n\n"
"// comment\n\n"
"for(var test in templateConfig) {\n"
" if( templateConfig ){ defaultLang = langParam; }\n"
"}\n\n"
"// end file")
subst = "{{$1}}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.