import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\/\\/\\s*?)(?:var|let|const)(?:\\s+)(.*?)(?:\\s+)?=\\s?(?:.*?);";
final String string = "// start file\n\n"
+ "var nameVar1 = '';\n"
+ "// var nameVar1 = '';\n\n"
+ "var otherVar1= \"test1\";\n\n"
+ "var nameVar2 =\"test2\",\n"
+ " otherVar2 = 'test3';\n"
+ " \n"
+ "var nameVar3 = true;\n\n"
+ "var otherVar3 = false ;\n\n"
+ "var objName = {\n"
+ " test: 'test'\n"
+ "};\n\n"
+ "var expression = nameVar1 + nameVar2;\n\n"
+ "// comment\n\n"
+ "for(var test in templateConfig) {\n"
+ " if( templateConfig ){ defaultLang = langParam; }\n"
+ "}\n\n"
+ "// end file";
final String subst = "{{$1}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}