const regex = /(?<!\/\/\s*?)(?:var|let|const)(?:\s+)(.*?)(?:\s+)?=\s?(?:.*?);/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\\/\\\/\\s*?)(?:var|let|const)(?:\\s+)(.*?)(?:\\s+)?=\\s?(?:.*?);', 'gms')
const str = `// start file
var nameVar1 = '';
// var nameVar1 = '';
var otherVar1= "test1";
var nameVar2 ="test2",
otherVar2 = 'test3';
var nameVar3 = true;
var otherVar3 = false ;
var objName = {
test: 'test'
};
var expression = nameVar1 + nameVar2;
// comment
for(var test in templateConfig) {
if( templateConfig ){ defaultLang = langParam; }
}
// end file`;
const subst = `{{$1}}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);