use strict;
my $str = '// start file
var nameVar1 = \'\';
// var nameVar1 = \'\';
var otherVar1= "test1";
var nameVar2 ="test2",
otherVar2 = \'test3\';
var nameVar3 = true;
var otherVar3 = false ;
var objName = {
test: \'test\'
};
var expression = nameVar1 + nameVar2;
// comment
for(var test in templateConfig) {
if( templateConfig ){ defaultLang = langParam; }
}
// end file';
my $regex = qr/(?<!\/\/\s*?)(?:var|let|const)(?:\s+)(.*?)(?:\s+)?=\s?(?:.*?);/msp;
my $subst = '{{$1}}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";