# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([A-Za-z]+(?: [A-Za-z]+)*|G20|EU28)\b.*$/$1/gm;t' <<< "Argentina -2.0 1.4
G20 6.9 0.7
United Kingdom 1.3 2.3
EU28 6.6 2.8"