use strict;
my $str = 'Argentina -2.0 1.4
G20 6.9 0.7
United Kingdom 1.3 2.3
EU28 6.6 2.8';
my $regex = qr/^([A-Za-z]+(?: [A-Za-z]+)*|G20|EU28)\b.*$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";