const regex = /^([A-Za-z]+(?: [A-Za-z]+)*|G20|EU28)\b.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([A-Za-z]+(?: [A-Za-z]+)*|G20|EU28)\\b.*$', 'gm')
const str = `Argentina -2.0 1.4
G20 6.9 0.7
United Kingdom 1.3 2.3
EU28 6.6 2.8`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);