import Foundation
let pattern = #"^([A-Za-z]+(?: [A-Za-z]+)*|G20|EU28)\b.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Argentina -2.0 1.4
G20 6.9 0.7
United Kingdom 1.3 2.3
EU28 6.6 2.8
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)