// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([A-Za-z]+(?: [A-Za-z]+)*|G20|EU28)\b.*$").unwrap();
let string = "Argentina -2.0 1.4
G20 6.9 0.7
United Kingdom 1.3 2.3
EU28 6.6 2.8";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}