# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[\s[A-Z]=(?<New_Field>[^\][]*)\s]/$11.0.0/gm;t' <<< "[ A=xaxxxxx ] [ B=weea case ] [ C=another example 0 ]"