package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\s[A-Z]=(?<New_Field>[^\][]*)\s]`)
var str = `[ A=xaxxxxx ] [ B=weea case ] [ C=another example 0 ]`
var substitution = "$11.0.0"
fmt.Println(re.ReplaceAllString(str, substitution))
}