const regex = /\[\s[A-Z]=(?<New_Field>[^\][]*)\s]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\s[A-Z]=(?<New_Field>[^\\][]*)\\s]', 'gm')
const str = `[ A=xaxxxxx ] [ B=weea case ] [ C=another example 0 ]`;
const subst = `$11.0.0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);